找出所有形如abc*de(三位数乘以两位数)的算式,使得在完整的竖式中,所有数字都属于一个特定的数字集合。输入数字集合(相邻数字之间没有空格),输出所有竖式。每个竖式前应有编号,之后应有一个空行。最后输出解的总数。具体格式见样例输出(为了便于观察,竖式中的空格改用小数点显示,但你的程序应该输出空格,而非小数点)。
样例输入:2357
样例输出:
<1>
..775
X..33
-----
.2325
2325.
-----
25575
The number of solutions = 1
down.cpp
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char In[10];
char buf[30];
int main()
{
int x,y,z,count;
int ok;
scanf("%s",In);
count = 0;
for(int abc = 100;abc <= 999;abc++)
{
for(int de = 10;de <= 99;de++)
{
x = abc*(de/10); y = abc*(de%10); z = abc*de;
sprintf(buf,"%d%d%d%d%d",abc,de,x,y,z);
ok = 1;
for(int i = 0; i < strlen(buf);i++)
{
if (strchr(In,buf[i])==NULL)
{
ok = 0;
break;
}
}
if (ok)
{
printf("<%d>\n",++count);
printf("%5d\nX%4d\n",abc,de);
printf("-----\n");
printf("%5d\n",x);
printf("%d\n",y);
printf("-----\n");
printf("%5d\n\n",z);
}
}
}
printf("The number of solutions = %d\n",count);
return 0;
}