A - Hashmat the Brave Warrior
Time Limit:3000MS Memory Limit:0KB 64bit IO Format:%lld & %llu
Description
Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.
Input
The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.
Output
For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.
Sample Input
10 12
10 14
100 200
Sample Output
2
4
100
本题主要是要注意Hashmat's soldier number is never greater than his opponent.这一句。所以读入后要比较一下大小。
UVA10055.cpp
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
long long a,b,c;
while(scanf("%lld%lld",&a,&b)!=EOF)
{
if (a > b)
{
c = a;
a = b;
b = c;
}
printf("%lld\n",b-a);
}
return 0;
}