Max Num
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10948 Accepted Submission(s): 7029
Problem Description
There are some students in a class, Can you help teacher find the highest student .
Input
There are some cases. The first line contains an integer t, indicate the cases; Each case have an integer n ( 1 ≤ n ≤ 100 ) , followed n students’ height.
Output
For each case output the highest height, the height to two decimal plases;
Sample Input
2
3 170.00 165.00 180.00
4 165.00 182.00 172.00 160.00
Sample Output
180.00
182.00
水题,不解释了
HDU2071.cpp
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
//freopen("out.txt","w",stdout);
double max = -1;
int T;
while(scanf("%d",&T)!=EOF)
{
for(int ii = 0;ii < T;ii++)
{
int n;
scanf("%d",&n);
max = -1;
double in;
for(int i = 0;i < n;i++)
{
scanf("%lf",&in);
if (in > max)
{
max = in;
}
}
printf("%.2lf\n",max);
}
}
return 0;
}