Posted on 2010-08-13 20:42
MiYu 阅读(1395)
评论(0) 编辑 收藏 引用 所属分类:
ACM ( 水题 )
MiYu原创, 转帖请注明 : 转载自 ______________白白の屋
题目地址:
http://acm.hdu.edu.cn/showproblem.php?pid=1215
题目描述:
七夕节
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10878 Accepted Submission(s): 2868
Problem Description
七夕节那天,月老来到数字王国,他在城门上贴了一张告示,并且和数字王国的人们说:"你们想知道你们的另一半是谁吗?那就按照告示上的方法去找吧!"
人们纷纷来到告示前,都想知道谁才是自己的另一半.告示如下:
数字N的因子就是所有比N小又能被N整除的所有正整数,如12的因子有1,2,3,4,6.
你想知道你的另一半吗?
Input
输入数据的第一行是一个数字T(1<=T<=500000),它表明测试数据的组数.然后是T组测试数据,每组测试数据只有一个数字N(1<=N<=500000).
Output
对于每组测试数据,请输出一个代表输入数据N的另一半的编号.
Sample Input
3
2
10
20
Sample Output
1
8
22
题目分析:
水题, 不要想复杂了 , 只需要 从2 循环到 sqrt(n), 判断是否能整除就可以了.........
代码如下:
#include <iostream>
#include <cmath>
using namespace std;
int set ( int num )
{
int bi = (int)sqrt( double ( num ) );
int sum = 1;
for( int i = 2; i <= bi; ++i)
{
if( num % i == 0)
{
sum += i;
int t = num / i;
if( t != i)
sum += t;
}
}
return sum;
}
int main()
{
int T;
int num;
while ( ~scanf ( "%d",&T ) )
{
while ( T-- )
{
scanf ( "%d",&num );
printf("%d\n",set(num));
}
}
return 0;
}