Cipher
Description
Bob
and Alice started to use a brand-new encoding scheme. Surprisingly it
is not a Public Key Cryptosystem, but their encoding and decoding is
based on secret keys. They chose the secret key at their last meeting
in Philadelphia on February 16th, 1996. They chose as a secret key a
sequence of n distinct integers, a1 ; . . .; an, greater than zero and
less or equal to n. The encoding is based on the following principle.
The message is written down below the key, so that characters in the
message and numbers in the key are correspondingly aligned. Character
in the message at the position i is written in the encoded message at
the position ai, where ai is the corresponding number in the key. And
then the encoded message is encoded in the same way. This process is
repeated k times. After kth encoding they exchange their message.
The length of the message is always less or equal than n. If the
message is shorter than n, then spaces are added to the end of the
message to get the message with the length n.
Help Alice and Bob and write program which reads the key and then a
sequence of pairs consisting of k and message to be encoded k times and
produces a list of encoded messages.
Input
The
input file consists of several blocks. Each block has a number 0 < n
<= 200 in the first line. The next line contains a sequence of n
numbers pairwise distinct and each greater than zero and less or equal
than n. Next lines contain integer number k and one message of ascii
characters separated by one space. The lines are ended with eol, this
eol does not belong to the message. The block ends with the separate
line with the number 0. After the last block there is in separate line
the number 0.
Output
Output
is divided into blocks corresponding to the input blocks. Each block
contains the encoded input messages in the same order as in input file.
Each encoded message in the output file has the lenght n. After each
block there is one empty line.
Sample Input
10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0
Sample Output
BolHeol b
C RCE
题意:
给出一个数组,然后给出一个数k和字符串,k表示该字符串按数组上与字符下标对应的数所表示的位移的置换次数。
比如:
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
则'H'对应 4,即是将H移到第四位。
这里k为1,最后结果是
BolHeol b
代码入下:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define maxn 300
int s[maxn], second[maxn];
void period(int n)//求出每一位的置换周期
{
int i, j, k;
for (i = 0; i < n; i++)
{
for (j = s[i], k = 1; j != i + 1; j = s[j - 1], k++);
second[i] = k;
}
}
int main()
{
int n, m, i, j, k, t;
char one[maxn], two[maxn];
while (scanf("%d", &n), n)
{
for (i = 0; i < n; i++)
{
scanf("%d", &s[i]);
}
period(n);
while (scanf("%d", &m), m)
{
getchar();
for (i = 0; i < n; i++)
{
scanf("%c", &one[i]);
if (one[i] == '\n')
{
break;
}
}
while (i < n)
{
one[i++] = ' ';
}
one[i] = two[i] = 0;
for (i = 0; i < n; i++)
{
k = m % second[i];
for (t = 0, j = i; t < k; t++)
{
j = s[j] - 1;
}//按置换次数求出one[i]最后所属的位置j
two[j] = one[i];
}
puts(two);
}
printf("\n");
}
return 0;
}