Nearest Common Ancestors
Description
A rooted tree is a well-known data structure in computer science and engineering. An example is shown below:
In the figure, each node is labeled with an integer from {1,
2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of
node y if node x is in the path between the root and node y. For
example, node 4 is an ancestor of node 16. Node 10 is also an ancestor
of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the
ancestors of node 16. Remember that a node is an ancestor of itself.
Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a
common ancestor of two different nodes y and z if node x is an ancestor
of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common
ancestors of nodes 16 and 7. A node x is called the nearest common
ancestor of nodes y and z if x is a common ancestor of y and z and
nearest to y and z among their common ancestors. Hence, the nearest
common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes
16 and 7 than node 8 is.
For other examples, the nearest common ancestor of nodes 2 and 3 is
node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and
the nearest common ancestor of nodes 4 and 12 is node 4. In the last
example, if y is an ancestor of z, then the nearest common ancestor of
y and z is y.
Write a program that finds the nearest common ancestor of two distinct nodes in a tree.
Input
The
input consists of T test cases. The number of test cases (T) is given
in the first line of the input file. Each test case starts with a line
containing an integer N , the number of nodes in a tree,
2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N.
Each of the next N -1 lines contains a pair of integers that represent
an edge --the first integer is the parent node of the second integer.
Note that a tree with N nodes has exactly N - 1 edges. The last line of
each test case contains two distinct integers whose nearest common
ancestor is to be computed.
Output
Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.
Sample Input
2
16
1 14
8 5
10 16
5 9
4 6
8 4
4 10
1 13
6 15
10 11
6 7
10 2
16 3
8 1
16 12
16 7
5
2 3
3 4
3 1
1 5
3 5
Sample Output
4
3
题意:给出树的结构,问两节点的最近公共父节点。
代码:
#include <stdio.h>
#include <vector>
#define maxn 10001
using namespace std;
int visit[maxn], indegree[maxn], f[maxn], ancestor[maxn];
vector<int> tree[maxn], que[maxn];
void init(int n)
{
int i;
for (i = 1; i <= n; i++)
{
tree[i].clear();
que[i].clear();
f[i] = -1;
visit[i] = 0;
indegree[i] = 0;
ancestor[i] = i;
}
}
int find(int a)
{
if (f[a] < 0)
{
return a;
}
return f[a] = find(f[a]);
}
void unions(int a, int b)
{
a = find(a), b = find(b);
if (a != b)
{
if (f[a] > f[b])
{
f[b] += f[a];
f[a] = b;
}
else
{
f[a] += f[b];
f[b] = a;
}
}
}
void lca(int u)
{
int i, size;
size = tree[u].size();
for (i = 0; i < size; i++)
{
lca(tree[u][i]);
unions(u, tree[u][i]);
ancestor[find(u)] = u;
/*对于处理过的孩子,其祖先要改为当前节点,保证这棵数的遍历逻辑,
因为并查集的合并是按权值而非遍历顺序合并的,通过并查集高效获得子树集合的端口,在通过这端口获得
该子树在这个时间段的真正最近父节点,如图中的4在并查树中会被归并为6的孩子,因为权值的问题*/
}
visit[u] = 1;
size = que[u].size();
for (i = 0; i < size; i++)
{
if (visit[que[u][i]] == 1)
{
printf("%d\n", ancestor[find(que[u][i])]);
return;
}
}
}
int main()
{
int n, t, i, u, v;
scanf("%d", &t);
while (t--)
{
scanf("%d", &n);
init(n);
for (i = 1; i < n; i++)
{
scanf("%d%d", &u, &v);
tree[u].push_back(v);
indegree[v]++;
}
scanf("%d%d", &u, &v);
que[u].push_back(v);
que[v].push_back(u);
for (i = 1; i <= n; i++)
{
if (indegree[i] == 0)
{
lca(i);
break;
}
}
}
return 0;
}