Redundant Paths
Description
In
order to get from one of the F (1 <= F <= 5,000) grazing fields
(which are numbered 1..F) to another field, Bessie and the rest of the
herd are forced to cross near the Tree of Rotten Apples. The cows are
now tired of often being forced to take a particular path and want to
build some new paths so that they will always have a choice of at least
two separate routes between any pair of fields. They currently have at
least one route between each pair of fields and want to have at least
two. Of course, they can only travel on Official Paths when they move
from one field to another.
Given a description of the current set of R (F-1 <= R <=
10,000) paths that each connect exactly two different fields, determine
the minimum number of new paths (each of which connects exactly two
fields) that must be built so that there are at least two separate
routes between any pair of fields. Routes are considered separate if
they use none of the same paths, even if they visit the same
intermediate field along the way.
There might already be more than one paths between the same pair of
fields, and you may also build a new path that connects the same fields
as some other path.
Input
Line 1: Two space-separated integers: F and R
Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.
Output
Line 1: A single integer that is the number of new paths that must be built.
Sample Input
7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7
Sample Output
2
题意:给出一个连通图,求至少添加多少条边,使得对于任意两点,不只一条路。即两点间的路去掉一条边还是连通的。
#include <stdio.h>
#include <stdlib.h>
#define Min(a, b) a < b ? a : b
#define maxn 5001
struct T
{
int v, next;
}fn[maxn * 4];
int g[maxn], indegree[maxn], visit[maxn], low[maxn];
void set(int n)
{
for (int i = 1; i <= n; i++)
{
g[i] = -1;
indegree[i] = 0;
visit[i] = 0;
}
}
int tarjan(int u, int f, int time)
{
int i, v;
visit[u] = 1;
low[u] = time;
for (i = g[u]; i != -1; i = fn[i].next)
{
v = fn[i].v;
if (v != f)
{
if(!visit[v])
{
time = tarjan(v, u, time + 1);
}
low[u] = Min(low[u], low[v]);
}
}
return time;
}
int isok(int u, int v)
{
int i;
for (i = g[u]; i != -1; i = fn[i].next)
{
if (fn[i].v == v)
{
//printf("ooo\n");
return 0;
}
}
return 1;
}
int main()
{
int n, m, u, v, th, sum, i, j;
while (scanf("%d%d", &n, &m) != EOF)
{
th = 0;
set(n);
while (m--)
{
scanf("%d%d", &u, &v);
if (isok(u,v))//处理重边,重边在求双连通分量时没影响,但在统计度时,由于重边也要重建,所以度会变多
{
fn[th].v = v, fn[th].next = g[u], g[u] = th++;
fn[th].v = u, fn[th].next = g[v], g[v] = th++;
}
}
tarjan(1, -1, 1);
for (i = 1; i <= n; i++)
{
for (j = g[i]; j != -1; j = fn[j].next)
{
if (low[i] != low[fn[j].v])
{
indegree[low[i]]++;
}
}
}
for (i = 1, sum = 0; i <= n; i++)
{
if (indegree[i] == 1)
{
sum++;
}
}
printf("%d\n", (sum + 1) / 2);
}
//system("pause");
return 0;
}
/*
首先这道题有重边,如
2 2
1 2
1 2
应该输出 1
2 2
1 2
2 1
*/