Dream City
Time Limit: 1 Second Memory Limit: 32768 KB
JAVAMAN is visiting Dream City and he sees a yard of gold coin trees. There are n trees in the yard. Let's call them tree 1, tree 2 ...and tree n. At the first day, each tree i has ai coins on it (i=1, 2, 3...n). Surprisingly, each tree i can grow bi new coins each day if it is not cut down. From the first day, JAVAMAN can choose to cut down one tree each day to get all the coins on it. Since he can stay in the Dream City for at most m days, he can cut down at most m trees in all and if he decides not to cut one day, he cannot cut any trees later. (In other words, he can only cut down trees for consecutive m or less days from the first day!)
Given n, m, ai and bi (i=1, 2, 3...n), calculate the maximum number of gold coins JAVAMAN can get.
Input
There are multiple test cases. The first line of input contains an integer T (T <= 200) indicates the number of test cases. Then T test cases follow.
Each test case contains 3 lines: The first line of each test case contains 2 positive integers n and m (0 < m <= n <= 250) separated by a space. The second line of each test case contains n positive integers separated by a space, indicating ai. (0 < ai <= 100, i=1, 2, 3...n) The third line of each test case also contains n positive integers separated by a space, indicating bi. (0 < bi <= 100, i=1, 2, 3...n)
Output
For each test case, output the result in a single line.
Sample Input
2
2 1
10 10
1 1
2 2
8 10
2 3
Sample Output
10
21
Hints:
Test case 1: JAVAMAN just cut tree 1 to get 10 gold coins at the first day.
Test case 2: JAVAMAN cut tree 1 at the first day and tree 2 at the second day to get 8 + 10 + 3 = 21 gold coins in all.
#include<iostream>
#include<stdio.h>
#include<algorithm>
using namespace std;
struct P
{
int x,y;
}a[300];
bool cmp( P x,P y )
{
return x.y<y.y;
}
int f(int x,int y)
{
if(x>y)
return x;
return y;
}
int main()
{
int dp[300][300],i,j,m,n,t;
cin>>t;
while(t--)
{
cin>>n>>m;
for(i=1;i<=n;i++)
scanf("%d",&a[i].x);
for(i=1;i<=n;i++)
scanf("%d",&a[i].y);
sort(a+1,a+n+1,cmp);
dp[0][0]=0;
for(i=1;i<=m;i++)
{
dp[i][i]=dp[i-1][i-1]+a[i].x+a[i].y*(i-1);
for(j=i+1;j<=n;j++)
dp[i][j]=f(dp[i][j-1],dp[i-1][j-1]+a[j].x+a[j].y*(i-1));
}
printf("%d\n",dp[m][n]);
}
return 0;
}