Division
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 999999/400000 K (Java/Others)
Total Submission(s): 961 Accepted Submission(s): 310
Problem Description
Little D is really interested in the theorem of sets recently. There’s a problem that confused him a long time.
Let T be a set of integers. Let the MIN be the minimum integer in T and MAX be the maximum, then the cost of set T if defined as (MAX – MIN)^2. Now given an integer set S, we want to find out M subsets S1, S2, …, SM of S, such that
and the total cost of each subset is minimal.
Input
The input contains multiple test cases.
In the first line of the input there’s an integer T which is the number of test cases. Then the description of T test cases will be given.
For any test case, the first line contains two integers N (≤ 10,000) and M (≤ 5,000). N is the number of elements in S (may be duplicated). M is the number of subsets that we want to get. In the next line, there will be N integers giving set S.
Output
For each test case, output one line containing exactly one integer, the minimal total cost. Take a look at the sample output for format.
Sample Input
Sample Output
Case 1: 1
Case 2: 18
Hint
The answer will fit into a 32-bit signed integer.
Source
四边形不等式优化,我掌握的确实不怎么样。。。
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
#define N 10009
#define INF 0x3fffffff
int n, m, a[ N ];
int solve() {
static int f[ 2 ][ N ], s[ 2 ][ N ];
int i, j, k, cur, pre, tmp;
cur = 0;
for ( i = 1; i <= n; ++i ) {
f[ cur ][ i ] = (a[i]-a[1])*(a[i]-a[1]);
s[ cur ][ i ] = 1;
}
for ( j = 2; j <= m; ++j ) {
pre = cur;
cur ^= 1;
s[ cur ][ n + 1 ] = n - 1;
for ( i = n; i >= j; --i ) {
f[ cur ][ i ] = INF;
for ( k = s[ pre ][ i ]; k <= s[ cur ][ i + 1 ]; ++k ) {
tmp = f[ pre ][ k ] + (a[i]-a[k+1])*(a[i]-a[k+1]);
if ( tmp < f[ cur ][ i ] ) {
f[ cur ][ i ] = tmp;
s[ cur ][ i ] = k;
}
}
}
}
return f[ cur ][ n ];
}
int main() {
int tc, cc, i;
scanf( "%d", &tc );
for ( cc = 1; cc <= tc; ++cc ) {
scanf( "%d%d", &n, &m );
for ( i = 1; i <= n; ++i ) {
scanf( "%d", a + i );
}
sort( a + 1, a + n + 1 );
printf( "Case %d: %d\n", cc, solve() );
}
return 0;
}