poj1837

Balance

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6149 Accepted: 3687

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm's length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: '-' for the left arm and '+' for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights' values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

额, 现在看见英语的描述就恶心,强忍着看明白的,

就是有个天平,上面有许多挂砝码的位置,然后给你许多砝码,问共有多少种方法使得天平平衡

第一行给出位置数和砝码,第二行给出位置,从小到大的

第三行给出每个砝码的重量。

很显然的背包

f[i][j+a[k]*b[i]]=f[i-1][j]+f[i][j+a[k]*b[i]];

我觉得这个方程特别丑,等会再改改

 1#include<stdio.h>
 2#include<string.h>
 3#include<math.h>
 4int i,j,k,n,m;
 5int a[25],b[25];
 6int f[25][15100];
 7int main()
 8{
 9    scanf("%d%d",&n,&m);
10    for (i=1; i<=n ; i++) scanf("%d",&a[i]);
11    for (i=1; i<=m ; i++) scanf("%d",&b[i]);
12    memset(f,0,sizeof(f));
13    f[0][7500]=1;
14    for (i=1; i<=m ; i++ )
15        for (j=1; j<=15000 ; j++ )
16            for (k=1; k<=n ; k++ )
17                if (f[i-1][j]>0)
18                {
19                    f[i][j+b[i]*a[k]]=f[i][j+b[i]*a[k]]+f[i-1][j];
20                }

21    printf("%d\n",f[m][7500]);
22    return 0;
23}

24




这样就好多了

f[i][j]=f[i-1][j-b[i]*a[k]]+f[i][j]

 1#include<stdio.h>
 2#include<string.h>
 3#include<math.h>
 4int i,j,k,n,m;
 5int a[25],b[25];
 6int f[25][15100];
 7int main()
 8{
 9    scanf("%d%d",&n,&m);
10    for (i=1; i<=n ; i++) scanf("%d",&a[i]);
11    for (i=1; i<=m ; i++) scanf("%d",&b[i]);
12    memset(f,0,sizeof(f));
13    f[0][7500]=1;
14    for (i=1; i<=m ; i++ )
15       
16            for (k=1; k<=n ; k++ )
17                 for (j=a[k]*b[i]+1; j<=15000 ; j++ )
18                if (f[i-1][j-a[k]*b[i]]>0)
19                {
20                    f[i][j]=f[i][j]+f[i-1][j-a[k]*b[i]];
21                }

22    printf("%d\n",f[m][7500]);
23    return 0;
24}

25

posted on 2012-02-19 21:25 jh818012 阅读(360) 评论(0)  编辑 收藏 引用


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2024年7月>
30123456
78910111213
14151617181920
21222324252627
28293031123
45678910

导航

统计

常用链接

留言簿

文章档案(85)

搜索

最新评论