poj1080

Human Gene Functions
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12791 Accepted: 7075

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 
这题是最长公共子列的变形
但是我wa了两遍,为什么呢,最后的答案不一定是正数
所以在赋初值的时候要赋为负的
  1#include<stdio.h>
  2#include<string.h>
  3#include<math.h>
  4int a[10][10],l1,l2;
  5char s1[150],s2[150];
  6int f[150][150],f1[150],f2[150];
  7void init()
  8{
  9    int i;
 10    scanf("%d %s",&l1,&s1);
 11    for (i=1; i<=l1 ; i++ )
 12    {
 13        switch (s1[i-1])
 14        {
 15        case 'A':
 16            f1[i]=1;
 17            break;
 18        case 'C':
 19            f1[i]=2;
 20            break;
 21        case 'G':
 22            f1[i]=3;
 23            break;
 24        case 'T':
 25            f1[i]=4;
 26            break;
 27        }

 28    }

 29    scanf("%d %s",&l2,&s2);
 30    for (i=1; i<=l2 ; i++ )
 31    {
 32        switch (s2[i-1])
 33        {
 34        case 'A':
 35            f2[i]=1;
 36            break;
 37        case 'C':
 38            f2[i]=2;
 39            break;
 40        case 'G':
 41            f2[i]=3;
 42            break;
 43        case 'T':
 44            f2[i]=4;
 45            break;
 46        }

 47    }

 48}

 49int max(int a,int b)
 50{
 51    if (a>b) return a;
 52    else return b;
 53}

 54void work()
 55{
 56    int i,j;
 57    for (i=0; i<150;i++ )
 58    {
 59        for (j=0;j<150 ;j++ )
 60        {
 61            f[i][j]=-100000000;
 62        }

 63    }

 64    f[0][0]=0;
 65    for (i=1; i<=l1 ; i++ )
 66        f[i][0]=f[i-1][0]+a[f1[i]][5];
 67    for (i=1; i<=l2; i++)
 68        f[0][i]=f[0][i-1]+a[5][f2[i]];
 69    for (i=1; i<=l1 ; i++ )
 70    {
 71        for (j=1; j<=l2; j++ )
 72        {
 73            f[i][j]=max(f[i][j],f[i-1][j-1]+a[f1[i]][f2[j]]);
 74            f[i][j]=max(f[i][j],f[i-1][j]+a[f1[i]][5]);
 75            f[i][j]=max(f[i][j],f[i][j-1]+a[5][f2[j]]);
 76        }

 77    }

 78}

 79int main()
 80{
 81    int t,i;
 82    scanf("%d",&t);
 83    for (i=1; i<=4 ; i++ ) a[i][i]=5;
 84    a[1][2]=-1;
 85    a[1][3]=-2;
 86    a[1][4]=-1;
 87    a[1][5]=-3;
 88    a[2][1]=-1;
 89    a[2][3]=-3;
 90    a[2][4]=-2;
 91    a[2][5]=-4;
 92    a[3][1]=-2;
 93    a[3][2]=-3;
 94    a[3][4]=-2;
 95    a[3][5]=-2;
 96    a[4][1]=-1;
 97    a[4][2]=-2;
 98    a[4][3]=-2;
 99    a[4][5]=-1;
100    a[5][1]=-3;
101    a[5][2]=-4;
102    a[5][3]=-2;
103    a[5][4]=-1;
104    a[5][5]=0;
105    while (t)
106    {
107        init();
108        work();
109        printf("%d\n",f[l1][l2]);
110        t--;
111    }

112    return 0;
113}

114

posted on 2012-02-20 17:20 jh818012 阅读(185) 评论(0)  编辑 收藏 引用


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2024年7月>
30123456
78910111213
14151617181920
21222324252627
28293031123
45678910

导航

统计

常用链接

留言簿

文章档案(85)

搜索

最新评论