The Unique MST
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 13200 |
|
Accepted: 4575 |
Description
Given a connected undirected graph, tell if its minimum spanning tree is unique.
Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.
Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!
裸的判定最小生成树是否唯一
做法
1,对图中每一条边,如果存在与之相等的其他的边,则标记这条边
2,求一次最小生成树,得到weight1,作为比较用
3,对于最小生成树中的每一条边,检查这条边有没有与之相同的,如果有,则删掉这条边,
再求最小生成树,如果相等,则说明最小生成树不唯一
判断完所有要判断的边后任然不相等,说明最小生成树唯一 1
#include<algorithm>
2
#include<cstdlib>
3
using namespace std;
4
#define maxn 101
5
#define maxm 15000
6
struct node
7![](/Images/OutliningIndicators/ExpandedBlockStart.gif)
![](/Images/OutliningIndicators/ContractedBlock.gif)
{
8
int u,v,w;
9
int equal,used,del;
10
} edge[maxm];
11
int n,m;
12
int parent[maxn];
13
int first;
14
void ufset()
15![](/Images/OutliningIndicators/ExpandedBlockStart.gif)
![](/Images/OutliningIndicators/ContractedBlock.gif)
{
16
int i;
17
for(i=1; i<=n; i++) parent[i]=-1;
18
}
19
int find(int x)
20![](/Images/OutliningIndicators/ExpandedBlockStart.gif)
![](/Images/OutliningIndicators/ContractedBlock.gif)
{
21
int s;
22
for(s=x; parent[s]>=0; s=parent[s]);
23
while(s!=x)
24![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
25
int tmp=parent[x];
26
parent[x]=s;
27
x=tmp;
28
}
29
return s;
30
}
31
void union1(int R1,int R2)
32![](/Images/OutliningIndicators/ExpandedBlockStart.gif)
![](/Images/OutliningIndicators/ContractedBlock.gif)
{
33
int r1=find(R1),r2=find(R2);
34
int tmp=parent[r1]+parent[r2];
35
if (parent[r1]>parent[r2])//r2所在树节点数多于r1
36![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
37
parent[r1]=r2;
38
parent[r2]=tmp;
39
}
40
else
41![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
42
parent[r2]=r1;
43
parent[r1]=tmp;
44
}
45
}
46
int cmp(struct node a,struct node b)
47![](/Images/OutliningIndicators/ExpandedBlockStart.gif)
![](/Images/OutliningIndicators/ContractedBlock.gif)
{
48
return a.w<b.w;
49
}
50
int kruskal()
51![](/Images/OutliningIndicators/ExpandedBlockStart.gif)
![](/Images/OutliningIndicators/ContractedBlock.gif)
{
52
int sumweight=0,num=0;
53
int u,v;
54
ufset();
55
for(int i=0; i<m; i++)
56![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
57
if (edge[i].del==1)
58![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
59
continue;
60
}
61
u=edge[i].u;
62
v=edge[i].v;
63
if (find(u)!=find(v))
64![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
65
sumweight+=edge[i].w;
66
num++;
67
union1(u,v);
68
if (first)
69![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
70
edge[i].used=1;
71
}
72
}
73
if (num>=n-1)
74![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
75
break;
76
}
77
}
78
return sumweight;
79
}
80
int main()
81![](/Images/OutliningIndicators/ExpandedBlockStart.gif)
![](/Images/OutliningIndicators/ContractedBlock.gif)
{
82
int t,i,j,k;
83
int u,v,w;
84
scanf("%d",&t);
85
for(i=1; i<=t; i++)
86![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
87
scanf("%d%d",&n,&m);
88
memset(edge,0,sizeof(edge));
89
for(j=0; j<m; j++)
90![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
91
scanf("%d%d%d",&u,&v,&w);
92
edge[j].u=u;
93
edge[j].v=v;
94
edge[j].w=w;
95
}
96
for(j=0; j<m; j++)
97
for(k=0; k<m; k++)
98![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
99
if (k==j) continue;
100
if (edge[j].w==edge[k].w) edge[j].equal=1;
101
}
102
sort(edge,edge+m,cmp);
103
first=1;
104
int weight1=kruskal(),weight2;
105
first=0;
106
for(j=0;j<m;j++)
107![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
108
if (edge[j].used==1&&edge[j].equal==1)
109![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
110
edge[j].del=1;
111
weight2=kruskal();
112
if (weight2==weight1)
113![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
114
printf("Not Unique!\n");
115
break;
116
}
117
edge[j].del=0;
118
}
119
}
120
if (j>=m)
121![](/Images/OutliningIndicators/ExpandedSubBlockStart.gif)
{
122
printf("%d\n",weight1);
123
}
124
}
125
return 0;
126
}
127![](/Images/OutliningIndicators/None.gif)