Window Pains
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 1090 |
|
Accepted: 540 |
Description
Boudreaux likes to multitask, especially when it comes to using his computer. Never satisfied with just running one application at a time, he usually runs nine applications, each in its own window. Due to limited screen real estate, he overlaps these windows and brings whatever window he currently needs to work with to the foreground. If his screen were a 4 x 4 grid of squares, each of Boudreaux's windows would be represented by the following 2 x 2 windows:
1 |
1 |
. |
. |
1 |
1 |
. |
. |
. |
. |
. |
. |
. |
. |
. |
. | |
. |
2 |
2 |
. |
. |
2 |
2 |
. |
. |
. |
. |
. |
. |
. |
. |
. | |
. |
. |
3 |
3 |
. |
. |
3 |
3 |
. |
. |
. |
. |
. |
. |
. |
. | |
. |
. |
. |
. |
4 |
4 |
. |
. |
4 |
4 |
. |
. |
. |
. |
. |
. | |
. |
. |
. |
. |
. |
5 |
5 |
. |
. |
5 |
5 |
. |
. |
. |
. |
. | |
. |
. |
. |
. |
. |
. |
6 |
6 |
. |
. |
6 |
6 |
. |
. |
. |
. | |
. |
. |
. |
. |
. |
. |
. |
. |
7 |
7 |
. |
. |
7 |
7 |
. |
. | |
. |
. |
. |
. |
. |
. |
. |
. |
. |
8 |
8 |
. |
. |
8 |
8 |
. | |
. |
. |
. |
. |
. |
. |
. |
. |
. |
. |
9 |
9 |
. |
. |
9 |
9 | |
When Boudreaux brings a window to the foreground, all of its squares come to the top, overlapping any squares it shares with other windows. For example, if window
1and then window
2 were brought to the foreground, the resulting representation would be:
1 |
2 |
2 |
? |
1 |
2 |
2 |
? |
? |
? |
? |
? |
? |
? |
? |
? | |
If window 4 were then brought to the foreground: |
1 |
2 |
2 |
? |
4 |
4 |
2 |
? |
4 |
4 |
? |
? |
? |
? |
? |
? | |
. . . and so on . . .
Unfortunately, Boudreaux's computer is very unreliable and crashes often. He could easily tell if a crash occurred by looking at the windows and seeing a graphical representation that should not occur if windows were being brought to the foreground correctly. And this is where you come in . . .
Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.
A single data set has 3 components:
- Start line - A single line:
START
- Screen Shot - Four lines that represent the current graphical representation of the windows on Boudreaux's screen. Each position in this 4 x 4 matrix will represent the current piece of window showing in each square. To make input easier, the list of numbers on each line will be delimited by a single space.
- End line - A single line:
END
After the last data set, there will be a single line:
ENDOFINPUT
Note that each piece of visible window will appear only in screen areas where the window could appear when brought to the front. For instance, a 1 can only appear in the top left quadrant.
Output
For each data set, there will be exactly one line of output. If there exists a sequence of bringing windows to the foreground that would result in the graphical representation of the windows on Boudreaux's screen, the output will be a single line with the statement:
THESE WINDOWS ARE CLEAN
Otherwise, the output will be a single line with the statement:
THESE WINDOWS ARE BROKEN
Sample Input
START
1 2 3 3
4 5 6 6
7 8 9 9
7 8 9 9
END
START
1 1 3 3
4 1 3 3
7 7 9 9
7 7 9 9
END
ENDOFINPUT
Sample Output
THESE WINDOWS ARE CLEAN
THESE WINDOWS ARE BROKEN
图论的好题
把模型建为网络,然后判断是否为AOV网
如何构图
预处理要先计算出4*4格的位置可能填放的窗口
读取快照后,对每一点处理如下
该点当前的窗口为k,对该点可能出现窗口i,标记g[k][i]有边
正常的话,不会出现环
这里判断AOV网用点的入度计算
如果存在超过未删除的点的入度全部大于0,说明存在环
#include<algorithm>
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
using namespace std;
string cover[4][4];
bool exist[10];//第i个窗口是否在快照中出现
int id[10];//入度
bool g[10][10];
int t;//顶点数
int n=4;
int a[4][4];
void getweizhi()
{
int i,j,k;
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
cover[i][j].erase();
}
for(k=1;k<=9;k++)
{
i=(k-1)/3;
j=(k-1)%3;
cover[i][j]+=char(k+'0');
cover[i][j+1]+=char(k+'0');
cover[i+1][j]+=char(k+'0');
cover[i+1][j+1]+=char(k+'0');
}
}
void init()
{
int i,j,k;
memset(g,0,sizeof(g));
memset(exist,false,sizeof(exist));
memset(id,0,sizeof(id));
t=0;
for(i=0;i<4;i++)
{
for(j=0;j<4;j++)
{
cin>>k;
a[i][j]=k;
if (!exist[k])
{
t++;
exist[k]=true;
}
}
}
}
void build()
{
int i,j,p;
for(i=0;i<n;i++)
for(j=0;j<n;j++)
{
for(p=0;p<=cover[i][j].length()-1;p++)
if (cover[i][j][p]-'0'!=a[i][j]&&!(g[a[i][j]][cover[i][j][p]-'0']))
{
g[a[i][j]][cover[i][j][p]-'0']=true;
id[cover[i][j][p]-'0']++;
}
}
}
bool check()
{
int i,j,k;
for(k=0;k<t;k++)
{
i=1;
while(!exist[i]||(i<=9&&id[i]>0)) i++;
if (i>9)//剩余的点中每个点入度都超过0
{
return false;
}
exist[i]=false;
for(j=1;j<=9;j++)
if (exist[j]&&g[i][j]) id[j]--;
}
return true;
}
int main()
{
string tmp;
getweizhi();
while(cin>>tmp)
{
if (tmp=="ENDOFINPUT")
{
break;
}
init();
build();
if (check())
cout<<"THESE WINDOWS ARE CLEAN"<<endl;
else
cout<<"THESE WINDOWS ARE BROKEN"<<endl;
cin>>tmp;
}
return 0;
}