The Doors
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 3721 |
|
Accepted: 1604 |
Description
You are to find the length of the shortest path through a chamber containing obstructing walls. The chamber will always have sides at x = 0, x = 10, y = 0, and y = 10. The initial and final points of the path are always (0, 5) and (10, 5). There will also be from 0 to 18 vertical walls inside the chamber, each with two doorways. The figure below illustrates such a chamber and also shows the path of minimal length.
Input
The input data for the illustrated chamber would appear as follows.
2
4 2 7 8 9
7 3 4.5 6 7
The first line contains the number of interior walls. Then there is a line for each such wall, containing five real numbers. The first number is the x coordinate of the wall (0 < x < 10), and the remaining four are the y coordinates of the ends of the doorways in that wall. The x coordinates of the walls are in increasing order, and within each line the y coordinates are in increasing order. The input file will contain at least one such set of data. The end of the data comes when the number of walls is -1.
Output
The output should contain one line of output for each chamber. The line should contain the minimal path length rounded to two decimal places past the decimal point, and always showing the two decimal places past the decimal point. The line should contain no blanks.
Sample Input
1
5 4 6 7 8
2
4 2 7 8 9
7 3 4.5 6 7
-1
Sample Output
10.00
10.06
这是黑书上的题目,貌似简化了些
做法就不解释了
主要是处理细节,主要判断线段是否相交//只考虑规范相交即可
构图后求最短路即可
#include<algorithm>
#include<iostream>
#include<string>
#include<math.h>
#define inf 0x7ffffff
#define max 100
using namespace std;
int n;
struct point
{
double x,y;
};
struct node
{
int u,v;
};
double wx[20];//每堵墙x坐标
point p[max];
int psize;
double py[20][4];
double g[max][max];
node e[max*max];
int esize;
double dis(point a,point b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double cross(double x1,double y1,double x2,double y2,double x3,double y3)//判断point3在线段(1,2)上面还是下面,叉积
{
return (x2-x1)*(y3-y1)-(x3-x1)*(y2-y1);
}
bool isok(point a,point b)//判断两点之间能不能连边
{
if (a.x>=b.x) return false;
bool flag=true;
int i;
i=0;
while (wx[i]<=a.x&&i<n) i++;
while(wx[i]<b.x && i<n)
{
if ( cross(a.x,a.y,b.x,b.y,wx[i],0)*cross(a.x,a.y,b.x,b.y,wx[i],py[i][0])<0
|| cross(a.x,a.y,b.x,b.y,wx[i],py[i][1])*cross(a.x,a.y,b.x,b.y,wx[i],py[i][2])<0
|| cross(a.x,a.y,b.x,b.y,wx[i],py[i][3])*cross(a.x,a.y,b.x,b.y,wx[i],10)<0)
{
flag=false;
break;
}
i++;
}
return flag;
}
double bellmanford(int beg,int end)//求最短路 这里边数相对较少,也可用spfa,或其他
{
bool ex=true;
double d[max];
int i,j;
for(i=0;i<max;i++) d[i]=inf;
d[beg]=0;
for(i=0;i<psize && ex;i++)
{
ex=false;
for(j=0;j<esize;j++)
{
if (d[e[j].u]<inf && d[e[j].v]>d[e[j].u]+g[e[j].u][e[j].v])
{
d[e[j].v]=d[e[j].u]+g[e[j].u][e[j].v];
ex=true;
}
}
}
return d[end];
}
void solve()
{
int i,j;
p[0].x=0;
p[0].y=5;
psize=1;
for(i=0; i<n; i++)
{
scanf("%lf",&wx[i]);
for(j=0; j<4; j++)
{
p[psize].x=wx[i];
scanf("%lf",&p[psize].y);
py[i][j]=p[psize].y;
psize++;
}
}
p[psize].x=10;
p[psize].y=5;
psize++;
for(i=0; i<psize; i++)
{
for(j=0; j<psize; j++)
{
g[i][j]=inf;
}
}
esize=0;
for(i=0; i<psize; i++)
for(j=i+1; j<psize; j++)
{
if (isok(p[i],p[j]))
{
g[i][j]=dis(p[i],p[j]);
e[esize].u=i;
e[esize].v=j;
esize++;
}
}
printf("%.2lf\n",bellmanford(0,psize-1));
}
int main()
{
while(scanf("%d",&n)!=EOF&&n!=-1)
{
solve();
}
return 0;
}