Burn the Linked Camp
Time Limit: 2 Seconds Memory Limit: 65536 KB
It is well known that, in the period of The Three Empires, Liu Bei, the emperor of the Shu Empire, was defeated by Lu Xun, a general of the Wu Empire. The defeat was due to Liu Bei's wrong decision that he divided his large troops into a number of camps, each of which had a group of armies, and located them in a line. This was the so-called "Linked Camps".
Let's go back to that time. Lu Xun had sent many scouts to obtain the information about his enemy. From his scouts, he knew that Liu Bei had divided his troops into n camps, all of which located in a line, labeled by 1..n from left to right. The ith camp had a maximum capacity of Ci soldiers. Furthermore, by observing the activities Liu Bei's troops had been doing those days, Lu Xun could estimate the least total number of soldiers that were lived in from the ith to the jth camp. Finally, Lu Xun must estimate at least how many soldiers did Liu Bei had, so that he could decide how many troops he should send to burn Liu Bei's Linked Camps.
Input:
There are multiple test cases! On the first line of each test case, there are two integers n (0<n<=1,000) and m (0<=m<=10,000). On the second line, there are n integers C1��Cn. Then m lines follow, each line has three integers i, j, k (0<i<=j<=n, 0<=k<2^31), meaning that the total number of soldiers from the ith camp to the jth camp is at least k.
Output:
For each test case, output one integer in a single line: the least number of all soldiers in Liu Bei's army from Lu Xun's observation. However, Lu Xun's estimations given in the input data may be very unprecise. If his estimations cannot be true, output "Bad Estimations" in a single line instead.
Sample Input:
3 2
1000 2000 1000
1 2 1100
2 3 1300
3 1
100 200 300
2 3 600
Sample Output:
1300
Bad Estimations
查分约束系统,可以当作模版
建立边的时候要注意有四组不等式
分别在代码中注释出了
注意,这里的边是有向边,举例,a-b<c的边应该是从b指向a,权值为c
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cmath>
using namespace std;
#define inf 0x7ffffff
#define maxn 1050
#define maxm 50000
int n,m;
int c[maxn];
int dist[maxn];
int d[maxn];
int ei;
struct node
{
int u,v,w;
} edge[maxm];
void init()
{
int i;
memset(d,0,sizeof(d));
ei=0;
for(i=0; i<=n; i++) dist[i]=inf;
dist[n]=0;
}
bool bellman_ford()
{
int i,k,t;
for(i=0; i<n; i++)
{
for(k=0; k<ei; k++)
{
t=dist[edge[k].u]+edge[k].w;
if (dist[edge[k].u]!=inf&&t<dist[edge[k].v])
{
dist[edge[k].v]=t;
}
}
}
for(k=0; k<ei; k++)
{
t=dist[edge[k].u]+edge[k].w;
if (dist[edge[k].u]!=inf && t<dist[edge[k].v])
{
return false;
}
}
return true;
}
int main()
{
int u,v,w,i;
while (scanf("%d%d",&n,&m)!=EOF)
{
init();
for(i=1; i<=n; i++)
{
scanf("%d",&c[i]);
edge[ei].u=i-1;//每个大营不能超过上限
edge[ei].v=i;
edge[ei].w=c[i];
ei++;
edge[ei].u=i;//每个大营人数大于0
edge[ei].v=i-1;
edge[ei].w=0;
ei++;
d[i]=d[i-1]+c[i];
}
for(i=0; i<m; i++)
{
scanf("%d%d%d",&u,&v,&w);
edge[ei].u=v;//u到v的大营总人数不少于w
edge[ei].v=u-1;
edge[ei].w=-w;
ei++;
edge[ei].u=u-1;//u到v的大营总人数少于上限
edge[ei].v=v;
edge[ei].w=d[v]-d[u-1];
ei++;
}
if (!bellman_ford())
{
printf("Bad Estimations\n");
}
else
{
printf("%d\n",dist[n]-dist[0]);
}
}
return 0;
}