THE MATRIX PROBLEM
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3993 Accepted Submission(s): 1022
Problem Description
You have been given a matrix CN*M, each element E of CN*M is positive and no more than 1000, The problem is that if there exist N numbers a1, a2, … an and M numbers b1, b2, …, bm, which satisfies that each elements in row-i multiplied with ai and each elements in column-j divided by bj, after this operation every element in this matrix is between L and U, L indicates the lowerbound and U indicates the upperbound of these elements.
Input
There are several test cases. You should process to the end of file.
Each case includes two parts, in part 1, there are four integers in one line, N,M,L,U, indicating the matrix has N rows and M columns, L is the lowerbound and U is the upperbound (1<=N、M<=400,1<=L<=U<=10000). In part 2, there are N lines, each line includes M integers, and they are the elements of the matrix.
Output
If there is a solution print "YES", else print "NO".
Sample Input
3 3 1 6 2 3 4 8 2 6 5 2 9
Sample Output
Source
额,查分约束系统
真心wa到爆,一直数组越界,最后发现边数开少了
用的spfa
判断 1 如果存在某顶点入队次数超过sqrt(n),说明存在负权回路,
2 如果总入队次数超过2*nn的话,存在负权回路,
不过第二种方法 速度比 第一种快多了
#include<math.h>
#include<stdio.h>
#include<string.h>
#define maxm 330000
#define maxn 1000
int n,m;
double l,u,ll,uu;
int q[1200000];
int head,tail;
struct node
{
int v,next;
double w;
} edge[maxm];
int p[maxn];
int e;
int nn;
int sec[maxn];
void add(int u,int v,double w)
{
edge[e].v=v;
edge[e].next=p[u];
edge[e].w=w;
p[u]=e++;
}
bool spfa()
{
int i,j,now;
int nnn;
bool flag[maxn];
double dist[maxn];
nnn=(int)(sqrt((double)(nn)));
memset(dist,0,sizeof(dist));
memset(sec,0,sizeof(sec));
memset(flag,0,sizeof(flag));
head=0;
tail=0;
for(i=1; i<=n; i++)
{
tail=tail%1200000+1;
q[tail]=i;
flag[i]=true;
sec[i]=1;
}
while (head!=tail)
{
head=head%1200000+1;
now=q[head];
if (sec[now]>nnn)
{
return false;
}
for(i=p[now]; i!=-1; i=edge[i].next)
{
if (dist[edge[i].v]>dist[now]+edge[i].w)
{
dist[edge[i].v]=dist[now]+edge[i].w;
if (!flag[edge[i].v])
{
sec[edge[i].v]++;
flag[edge[i].v]=true;
tail=tail%1200000+1;
q[tail]=edge[i].v;
}
}
}
flag[now]=false;
}
return true;
}
int main()
{
int i,j;
double x;
while (scanf("%d %d %lf %lf",&n,&m,&l,&u)!=EOF)
{
e=0;
ll=log(l);
uu=log(u);
memset(p,-1,sizeof(p));
for(i=1; i<=n; i++)
{
for(j=1; j<=m; j++)
{
scanf("%lf",&x);
x=log(x);
add(j+n,i,uu-x);
add(i,j+n,x-ll);
}
}
nn=n+m;
if (spfa())
{
printf("YES\n");
}
else printf("NO\n");
}
return 0;
}