Blue Jeans
Time Limit: 1000MS |
| Memory Limit: 65536K |
Total Submissions: 8079 |
| Accepted: 3376 |
Description
The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated.
As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers.
A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.
Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.
Input
Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:
- A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
- m lines each containing a single base sequence consisting of 60 bases.
Output
For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.
Sample Input
3 2 GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA 3 GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA 3 CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT
Sample Output
no significant commonalities AGATAC CATCATCAT
Source
暴力 枚举+kmp验证
我现在终于知道一个好模板有多重要了
我的渣渣kmp,让我wa过无数次题目了
void getnext()
{
long i,j;
j=-1;
p[0]=-1;//zheli -1
for (i=1;i<=m-1;i++)
{
while ((j!=-1)&&(t[j+1]!=t[i])) j=p[j];//zheli -1
if (t[j+1]==t[i]) j=j+1;
p[i]=j;
}
}
void kmp()
{
int i,j;
j=-1;
for (i=0;i<=n-1;i++)
{
while ((j!=-1)&&(t[j+1]!=s[i])) j=p[j];//zheliyeshi
if (t[j+1]==s[i]) j++;
if (j==m-1)
{
printf("Find at %d !",i-j+2);
j=p[j];
}
}
}
//就因为这个,改到崩溃
code
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <cassert>
#include <iostream>
#include <sstream>
#include <fstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <algorithm>
#include <iomanip>
using namespace std;
char str[15][105];
char strt[100],old[100],ans[100];
int p[100];
int len,n,l1;
void getnext()
{
int i,j;
memset(p,0,sizeof(p));
j=-1;
p[0]=-1;
for (i=1;i<strlen(strt);i++)
{
while ((j!=-1)&&(strt[j+1]!=strt[i])) j=p[j];
if (strt[j+1]==strt[i]) j=j+1;
p[i]=j;
}
}
bool kmp(char str1[])
{
int i,j,len2;
len2=strlen(strt);
j=-1;
for (i=0;i<60;i++)
{
while ((j!=-1)&&(strt[j+1]!=str1[i])) j=p[j];
if (strt[j+1]==str1[i]) j++;
if (j==len2-1)
{
return 1;
}
}
if (j!=len2-1)return 0;
else return 1;
}
bool cmp1(char strx[],char stry[])
{
int len1;
len1=strlen(strx);
int len2;
len2=strlen(stry);
int lenx=len1<len2?len1:len2;
for(int i=0; i<lenx; i++)
{
if (strx[i]>stry[i])
{
return 1;
}
else if(strx[i]<stry[i])
{
return 0;
}
}
if(len1>len2) return 1;
else return 0;
}
int main()
{
int t,i,j,k;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=1; i<=n; i++)
scanf("%s",str[i]);
len=60;
l1=0;
memset(ans,0,sizeof(ans));
memset(strt,0,sizeof(strt));
for(j=3; j<=len; j++)
for(i=0; i<=len-j; i++)
{
strcpy(old,strt);
for(k=i; k<i+j; k++)
strt[k-i]=str[1][k];
strt[k-i]='\0';
// puts(strt);
if(strcmp(old,strt)==0)continue;
getnext();
bool flag;
flag=true;
for(k=2; k<=n; k++)
{
if(kmp(str[k])==0)
{
flag=false;
break;
}
}
if(flag)
{
if(ans[0]==0)
strcpy(ans,strt);
else
{
if(strlen(strt)>strlen(ans))
{
//puts(ans);
strcpy(ans,strt);
}
else if(strlen(strt)==strlen(ans))
{
if(cmp1(ans,strt))
{
// puts(ans);
strcpy(ans,strt);
}
}
}
}
}
if(ans[0]!=0) printf("%s\n",ans);
else printf("no significant commonalities\n");
}
return 0;
}