Snowflake Snow Snowflakes
Time Limit: 4000MS |
|
Memory Limit: 65536K |
Total Submissions: 22730 |
|
Accepted: 5923 |
Description
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
Input
The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
Output
If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
Sample Input
2
1 2 3 4 5 6
4 3 2 1 6 5
Sample Output
Twin snowflakes found.
忽然发现自己已经好长时间没写过hash的题目了
这题写了半天,觉着写的特别混乱,然后删掉重新写
这样看起来简单多了
用的直接相加求和模大质数的hash
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <cassert>
#include <iostream>
#include <sstream>
#include <fstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <algorithm>
#include <iomanip>
#define maxn 100001
#define bp 999983
using namespace std;
struct node
{
int x[6];
int next;
} s[maxn],tmp;
int sec;
struct node2
{
int x[6];
void init()
{
for(int i=0; i<6; i++) scanf("%d",&x[i]);
}
} a[maxn];
int n;
int head[1000001];
bool flag[1000001];
int hs;
inline int hash(node2 t)
{
return (t.x[0]%bp+t.x[1]%bp+t.x[2]%bp+t.x[3]%bp+t.x[4]%bp+t.x[5]%bp)%bp;
}
void add(int hhh,node t)
{
s[sec]=t;
s[sec].next=head[hhh];
head[hhh]=sec++;
}
bool pans(node t1,node t2)
{
if(t1.x[0]==t2.x[0]&&t1.x[1]==t2.x[1]&&t1.x[2]==t2.x[2]&&t1.x[3]==t2.x[3]&&t1.x[4]==t2.x[4]&&t1.x[5]==t2.x[5]) return 1;
if(t1.x[0]==t2.x[1]&&t1.x[1]==t2.x[2]&&t1.x[2]==t2.x[3]&&t1.x[3]==t2.x[4]&&t1.x[4]==t2.x[5]&&t1.x[5]==t2.x[0]) return 1;
if(t1.x[0]==t2.x[2]&&t1.x[1]==t2.x[3]&&t1.x[2]==t2.x[4]&&t1.x[3]==t2.x[5]&&t1.x[4]==t2.x[0]&&t1.x[5]==t2.x[1]) return 1;
if(t1.x[0]==t2.x[3]&&t1.x[1]==t2.x[4]&&t1.x[2]==t2.x[5]&&t1.x[3]==t2.x[0]&&t1.x[4]==t2.x[1]&&t1.x[5]==t2.x[2]) return 1;
if(t1.x[0]==t2.x[4]&&t1.x[1]==t2.x[5]&&t1.x[2]==t2.x[0]&&t1.x[3]==t2.x[1]&&t1.x[4]==t2.x[2]&&t1.x[5]==t2.x[3]) return 1;
if(t1.x[0]==t2.x[5]&&t1.x[1]==t2.x[0]&&t1.x[2]==t2.x[1]&&t1.x[3]==t2.x[2]&&t1.x[4]==t2.x[3]&&t1.x[5]==t2.x[4]) return 1;
return 0;
}
bool pann(node t1,node t2)
{
node tmp1;
for(int i=0;i<6;i++) tmp1.x[i]=t1.x[5-i];
if(tmp1.x[0]==t2.x[0]&&tmp1.x[1]==t2.x[1]&&tmp1.x[2]==t2.x[2]&&tmp1.x[3]==t2.x[3]&&tmp1.x[4]==t2.x[4]&&tmp1.x[5]==t2.x[5]) return 1;
if(tmp1.x[0]==t2.x[1]&&tmp1.x[1]==t2.x[2]&&tmp1.x[2]==t2.x[3]&&tmp1.x[3]==t2.x[4]&&tmp1.x[4]==t2.x[5]&&tmp1.x[5]==t2.x[0]) return 1;
if(tmp1.x[0]==t2.x[2]&&tmp1.x[1]==t2.x[3]&&tmp1.x[2]==t2.x[4]&&tmp1.x[3]==t2.x[5]&&tmp1.x[4]==t2.x[0]&&tmp1.x[5]==t2.x[1]) return 1;
if(tmp1.x[0]==t2.x[3]&&tmp1.x[1]==t2.x[4]&&tmp1.x[2]==t2.x[5]&&tmp1.x[3]==t2.x[0]&&tmp1.x[4]==t2.x[1]&&tmp1.x[5]==t2.x[2]) return 1;
if(tmp1.x[0]==t2.x[4]&&tmp1.x[1]==t2.x[5]&&tmp1.x[2]==t2.x[0]&&tmp1.x[3]==t2.x[1]&&tmp1.x[4]==t2.x[2]&&tmp1.x[5]==t2.x[3]) return 1;
if(tmp1.x[0]==t2.x[5]&&tmp1.x[1]==t2.x[0]&&tmp1.x[2]==t2.x[1]&&tmp1.x[3]==t2.x[2]&&tmp1.x[4]==t2.x[3]&&tmp1.x[5]==t2.x[4]) return 1;
return 0;
}
int main()
{
scanf("%d",&n);
for(int i=1; i<=n; i++) a[i].init();
memset(flag,0,sizeof(flag));
memset(head,-1,sizeof(head));
sec=0;
bool isex;
isex=false;
for(int i=1; i<=n; i++)
{
hs=hash(a[i]);
if(!flag[hs])
{
flag[hs]=1;
for(int j=0; j<6; j++) tmp.x[j]=a[i].x[j];
add(hs,tmp);
}
else
{
for(int j=0; j<6; j++) tmp.x[j]=a[i].x[j];
for(int j=head[hs]; j!=-1; j=s[j].next)
{
if(pans(tmp,s[j])||pann(tmp,s[j]))
{
isex=1;
printf("Twin snowflakes found.\n");
return 0;
}
else
{
add(hs,tmp);
}
}
}
}
if(isex==0) printf("No two snowflakes are alike.\n");
return 0;
}