Escape Time II
Time Limit: 2 Seconds Memory Limit: 65536 KB
There is a fire in LTR ’ s home again. The fire can destroy all the things in t seconds, so LTR has to escape in t seconds. But there are some jewels in LTR ’ s rooms, LTR love jewels very much so he wants to take his jewels as many as possible before he goes to the exit. Assume that the ith room has ji jewels. At the beginning LTR is in room s, and the exit is in room e.
Your job is to find a way that LTR can go to the exit in time and take his jewels as many as possible.
Input
There are multiple test cases.
For each test case:
The 1st line contains 3 integers n (2 ≤ n ≤ 10), m, t (1 ≤ t ≤ 1000000) indicating the number of rooms, the number of edges between rooms and the escape time.
The 2nd line contains 2 integers s and e, indicating the starting room and the exit.
The 3rd line contains n integers, the ith interger ji (1 ≤ ji ≤ 1000000) indicating the number of jewels in the ith room.
The next m lines, every line contains 3 integers a, b, c, indicating that there is a way between room a and room b and it will take c (1 ≤ c ≤ t) seconds.
Output
For each test cases, you should print one line contains one integer the maximum number of jewels that LTR can take. If LTR can not reach the exit in time then output 0 instead.
Sample Input
3 3 5 0 2 10 10 10 0 1 1 0 2 2 1 2 3 5 7 9 0 3 10 20 20 30 20 0 1 2 1 3 5 0 3 3 2 3 2 1 2 5 1 4 4 3 4 2
Sample Output
30 80
Author:
FU, YujunContest:
ZOJ Monthly, June 2012 状态搜索,
搜索写了不少,但是以前几乎没写过这一类的题目,
要开始练搜索啊
code
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <cassert>
#include <iostream>
#include <sstream>
#include <fstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <algorithm>
#include <iomanip>
#define maxn 15
#define inf 1000000000
using namespace std;
int mp[maxn][maxn];
int t,n,m,s,e,ti,x,y;
int a[maxn];
long long ans;
struct node
{
int v,st,val,ti;
} tmp,tmp1;
queue<node> q;
int head,tail;
int get[15][1024];
int mt[15][1024];
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int res;
while(scanf("%d%d%d",&n,&m,&t)!=EOF)
{
scanf("%d%d",&s,&e);
for(int i=0; i<n; i++) scanf("%d",&a[i]);
for(int i=0; i<n; i++)
{
for(int j=i+1; j<n; j++)
mp[i][j]=mp[j][i]=inf;
}
for(int i=1; i<=m; i++)
{
scanf("%d%d%d",&x,&y,&ti);
if(ti<mp[x][y])
{
mp[x][y]=ti;
mp[y][x]=ti;
}
}
memset(get,0,sizeof(get));//这地方老是顺手写成sizeof(0)
for(int i=0; i<n; i++)
{
for(int j=0; j<(1<<n); j++)
{
mt[i][j]=inf;
}
}
get[s][1<<s]=a[s];
mt[s][1<<s]=0;
res=0;
tmp.v=s;
tmp.ti=0;
tmp.val=a[s];
tmp.st=1<<s;
q.push(tmp);
while(!q.empty())
{
tmp=q.front();
q.pop();
for(int i=0; i<n; i++)
{
if(i==tmp.v) continue;
if(mp[tmp.v][i]+tmp.ti<=t)
{
tmp1.val=tmp.val;
tmp1.st=tmp.st;
if(!((tmp1.st>>i)&1))
{
tmp1.st=tmp1.st|(1<<i);
tmp1.val+=a[i];
}
if(tmp1.val>get[i][tmp1.st]||(tmp1.val==get[i][tmp1.st]&&tmp.ti+mp[tmp.v][i]<mt[i][tmp1.st]))
{
get[i][tmp1.st]=tmp1.val;
mt[i][tmp1.st]=tmp.ti+mp[tmp.v][i];
tmp1.ti=mt[i][tmp1.st];
tmp1.v=i;
q.push(tmp1);
}
}
}
}
for(int i=0; i<(1<<n); i++)
res=max(get[e][i],res);
printf("%d\n",res);
}
return 0;
}