Cable master
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 15127 |
|
Accepted: 3200 |
Description
Inhabitants of the Wonderland have decided to hold a
regional programming contest. The Judging Committee has volunteered and has
promised to organize the most honest contest ever. It was decided to connect
computers for the contestants using a "star" topology - i.e. connect them all to
a single central hub. To organize a truly honest contest, the Head of the
Judging Committee has decreed to place all contestants evenly around the hub on
an equal distance from it.
To buy network cables, the Judging Committee has
contacted a local network solutions provider with a request to sell for them a
specified number of cables with equal lengths. The Judging Committee wants the
cables to be as long as possible to sit contestants as far from each other as
possible.
The Cable Master of the company was assigned to the task. He knows
the length of each cable in the stock up to a centimeter,and he can cut them
with a centimeter precision being told the length of the pieces he must cut.
However, this time, the length is not known and the Cable Master is completely
puzzled.
You are to help the Cable Master, by writing a program that will
determine the maximal possible length of a cable piece that can be cut from the
cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer
numb ers N and K, separated by a space. N (1 = N = 10000) is the number of
cables in the stock, and K (1 = K = 10000) is the number of requested pieces.
The first line is followed by N lines with one number per line, that specify the
length of each cable in the stock in meters. All cables are at least 1 meter and
at most 100 kilometers in length. All lengths in the input file are written with
a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in
meters) of the pieces that Cable Master may cut from the cables in the stock to
get the requested number of pieces. The number must be written with a centimeter
precision, with exactly two digits after a decimal point.
If it is not
possible to cut the requested number of pieces each one being at least one
centimeter long, then the output file must contain the single number "0.00"
(without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output
2.00
Source
|
坑爹的水题,
精度,精度!
code
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <cassert>
#include <iostream>
#include <sstream>
#include <fstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <algorithm>
#include <iomanip>
#define maxn 10005
using namespace std;
int n,k;
double a[maxn];
int b[maxn];
double mlen;
double max(double a,double b)
{
return a>b?a:b;
}
int getnum(__int64 x)
{
int tot;
if(x==0) return 100000;
tot=0;
for(int i=1; i<=n; i++) tot+=b[i]/x;
return tot;
}
int main()
{
scanf("%d%d",&n,&k);
__int64 sum;
mlen=-1;
for(int i=1; i<=n; i++)
{
scanf("%lf",&a[i]);
mlen=max(mlen,a[i]);
b[i]=(a[i]+0.005)*100;
sum+=b[i];
}
if(sum<k)
{
printf("0.00\n");
return 0;
}
__int64 left,right,mid;
left=0;
right=(int)((mlen+0.005)*100);
while(right-left>0)
{
// printf("%d %d\n",left,right);
mid=(left+right)/2+1;
if(getnum(mid)>=k)
left=mid;
else right=mid-1;
}
//printf("%d\n",mid);
printf("%.2lf\n",double(right)/100.0);
return 0;
}