Expanding Rods
Time Limit: 1000MS |
|
Memory Limit: 30000K |
Total Submissions: 8376 |
|
Accepted: 2058 |
Description
When a thin
rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L,
where C is the coefficient of heat expansion.
When a thin rod is mounted on
two solid walls and then heated, it expands and takes the shape of a circular
segment, the original rod being the chord of the segment.
Your task is
to compute the distance by which the center of the rod is displaced.
Input
The input contains multiple lines. Each line of input
contains three non-negative numbers: the initial lenth of the rod in
millimeters, the temperature change in degrees and the coefficient of heat
expansion of the material. Input data guarantee that no rod expands by more than
one half of its original length. The last line of input contains three negative
numbers and it should not be processed.
Output
For each line of input, output one line with the
displacement of the center of the rod in millimeters with 3 digits of precision.
Sample Input
1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1
Sample Output
61.329
225.020
0.000
Source
|
推一下公式
然后二分就可以了
可以二分的有很多
但是如果二分圆心角的话感觉特别简单
code
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <cassert>
#include <iostream>
#include <sstream>
#include <fstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <algorithm>
#include <iomanip>
using namespace std;
double l,ll,n,c;
int main()
{
double left,mid,right;
while(scanf("%lf%lf%lf",&l,&n,&c)!=EOF)
{
if(l==-1&&n==-1&&c==-1) break;
if(l==0||n==0||c==0)
{
printf("0.000\n");
continue;
}
ll=l*(1+n*c);
left=0;
right=acos(-1.0);
//二分角度
while(right-left>1e-12)
{
mid=(left+right)/2;
if(mid*l>2*ll*sin(mid/2))
right=mid;
else left=mid;
}
printf("%.3lf\n",(1-cos(mid/2))*l/(2*sin(mid/2)));
}
return 0;
}