Ignatius and the Princess III
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 100 Accepted Submission(s) : 83
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
Sample Output
Author
Ignatius.L
#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
int i,k,j,n;
int a[121],b[121];
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<=n;i++)
{
a[i]=1;
b[i]=0;
}
for(i=2;i<=n;i++)
{
for(j=0;j<=n;j++)//(1+x+x2+x3..xn)
for(k=0;k+j<=n;k+=i)//(1+x2+x4+x6..) 两层for循环 是用第一个循环中x的j次 来乘第二个循环中x的k次
b[j+k]+=a[j];
for(j=0;j<=n;j++)
{
a[j]=b[j];
b[j]=0;
}
}
printf("%d\n",a[n]);
}
return 0;
}