Holding Bin-Laden Captive!
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 132 Accepted Submission(s) : 69
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”
Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
Sample Input
Sample Output
Author
lcy
#include<stdio.h>
#include<string.h>
int main()
{
int i,j,k,a,b,c,d[10001];
while(scanf("%d %d %d",&a,&b,&c)!=EOF)
{
if(0==a&&0==b&&0==c)
break;
memset(d,0,sizeof(d));
for(j=0;j<=a;j++)
for(k=0;k+j<=a+2*b;k=k+2)
d[k+j]++;
for(j=0;j<=a+2*b&&d[j];j++)//&&a[j]是排除从0到a+2b之内不存在的项
for(k=0;k+j<=a+2*b+5*c;k=k+5)
d[k+j]++;
for(i=0;i<=a+2*b+5*c+1;i++)//+1是因为如果情况中的全满足 那么大于范围的第一个就是所求
{
if(d[i]==0)
{
printf("%d\n",i);
break;
}
}
}
return 0;
}