Description
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output
For each problem instance, output consists of one line. This line should be one of the following three:
Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.
where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.
Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0
Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
Source
拓扑排序算法: 1.将所有入度为0的点加入队列;
2.弹出队首元素u,输出u并将所有与u关联的顶点v的入度减1;如果v的入度为0,将u加入队列;
3.重复第2步,如果所有的顶点都被访问到,则输出序列是一个拓扑排序;否则该DAG图中存在环路。
#include <iostream>
#include <string>
#include <vector>
#include <queue>
using namespace std;
int n,m;
vector<int> top;
vector<int> in;
vector< vector<int> > map;
int topsort(){
int i,u;
bool flag=false;
queue<int> q;
vector<int> d(in.begin(),in.end());
for(i=0;i<n;i++)
if(!d[i]) q.push(i);
top.clear();
while(!q.empty()){
if(q.size()!=1) flag=true;
u=q.front();
q.pop();
top.push_back(u);
for(i=0;i<map[u].size();i++)
if(--d[map[u][i]]==0) q.push(map[u][i]);
}
if(top.size()!=n) return 1;
if(flag) return 0;
return 2;
}
int main(){
string str;
int i,j,u,v,ans;
while(cin>>n>>m,n||m){
in.assign(n,0);
map.assign(n,vector<int>());
for(ans=i=0;i<m && !ans;i++){
cin>>str;
u=str[0]-'A',v=str[2]-'A';
if(find(map[u].begin(),map[u].end(),v)==map[u].end())
map[u].push_back(v),in[v]++;
ans=topsort();
}
for(j=i;j<m;j++) cin>>str;
switch(ans){
case 0:cout<<"Sorted sequence cannot be determined."<<endl;break;
case 1:cout<<"Inconsistency found after "<<i<<" relations."<<endl;break;
case 2:{
cout<<"Sorted sequence determined after "<<i<<" relations: ";
for(j=0;j<n;j++) cout<<char('A'+top[j]);
cout<<"."<<endl;
break;
}
}
}
return 0;
}