Cipher
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12776 Accepted: 3194
Description
Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.
The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.
Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.
Input
The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.
Output
Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.
Sample Input
10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0
Sample Output
BolHeol b
C RCE
Source
Central Europe 1995
给定1~n的置换F,求其变换m次的变换F^m.
先找到循环节,再用m对循环节的长度取模即可.
#include <iostream>
using namespace std;
int main()
{
const int MAX=300;//最大长度
char str[MAX];//读入串
int n;//变换的长度
int data[MAX]={0};//存放原始变换
int used[MAX]={0};//标志数组
int cir[MAX][MAX]={0};//每个循环节的成员
int num[MAX]={0};//循环节对应长度
int cnt=0;//循环节的个数
int time=0;//变换次数
int change[MAX]={0};//原始循环变换time次之后的变换
char res[MAX]={0};//变换之后的字符串
int i,j;
while(cin>>n && n)
{
memset(used,0,sizeof(used));
memset(num,0,sizeof(num));
for(i=1;i<=n;i++)
cin>>data[i];
cnt=0;//计数循环节个数
for(i=1;i<=n;i++)
{
if(used[i]==0)
{
used[i]=1;
int temp=data[i];
cir[cnt][num[cnt]]=temp;
num[cnt]=1;
while(used[temp]==0)//获得循环节
{
used[temp]=1;
temp=data[temp];
cir[cnt][num[cnt]++]=temp;
}
cnt++;
}
}
while(cin>>time && time)//读入变换次数
{
memset(res,0,sizeof(res));
memset(str,0,sizeof(str));
gets(str);
int len=strlen(str);
for(i=len;i<=n;i++)//位数不足n,补空格
str[i]=' ';
//获得变换
for(i=0;i<cnt;i++)
{
for(j=0;j<num[i];j++)
{
change[cir[i][j]]=cir[i][(j+time)%num[i]];
}
}
//对读入数据变换,获得结果
for(i=1;i<=n;i++)
{
res[change[i]]=str[i];
}
cout<<res+1<<endl;
}
cout<<endl;
}
return 0;
}