Mixing Milk
Since milk packaging is such a low margin business, it is important
to keep the price of the raw product (milk) as low as possible. Help
Merry Milk Makers get the milk they need in the cheapest possible manner.
The Merry Milk Makers company has several farmers from which they
may buy milk, and each one has a (potentially) different price at which
they sell to the milk packing plant. Moreover, as a cow can only produce
so much milk a day, the farmers only have so much milk to sell per day.
Each day, Merry Milk Makers can purchase an integral amount of milk from
each farmer, less than or equal to the farmer's limit.
Given the Merry Milk Makers' daily requirement of milk, along with the cost
per gallon and amount of available milk for each farmer, calculate the
minimum amount of money that it takes to fulfill the Merry Milk Makers'
requirements.
Note: The total milk produced per day by the farmers will be sufficient
to meet the demands of the Merry Milk Makers.
PROGRAM NAME: milk
INPUT FORMAT
Line 1: |
Two integers, N and M. The first
value, N, (0 <= N <=
2,000,000) is the amount of milk that Merry Milk Makers' want per day.
The second, M, (0 <= M <= 5,000) is the number of farmers
that they may buy from.
|
Lines 2 through M+1: |
The next M lines each contain
two integers, Pi and Ai. Pi (0 <= Pi <= 1,000) is price in
cents that farmer i charges. Ai (0 <= Ai <= 2,000,000) is the amount
of milk that farmer i can sell to Merry Milk Makers per day.
|
SAMPLE INPUT (file milk.in)
100 5
5 20
9 40
3 10
8 80
6 30
OUTPUT FORMAT
A single line with a single integer that is the minimum price that
Merry Milk Makers can get their milk at for one day.
SAMPLE OUTPUT (file milk.out)
630
一个不完全背包,简单贪心,对fammer信息按price从小到大排序,
然后装进背包求minnum price就好了。
代码:
/*
ID: superlo1
LANG: C++
TASK: milk
*/
#include <iostream>
#include <algorithm>
using namespace std;
struct node
{
int p, a;
}fam[5001];
bool cmp(node a,node b)
{ return a.p < b.p; }
int n, m;
int main()
{
freopen("milk.in","r",stdin);
freopen("milk.out","w",stdout);
scanf("%d %d", &n, &m);
int i;
for(i = 0; i < m; i ++)
scanf("%d %d", &fam[i].p, &fam[i].a);
sort( fam, fam + m, cmp);
int ans = 0;
i = 0;
while(n)
{
if( n > fam[i].a)
{
n -= fam[i].a;
ans += fam[i].p * fam[i].a;
}
else
{
ans += n * fam[i].p;
n = 0;
}
i ++;
}
printf("%d\n",ans);
//while(1);
}
优化:以上为O(n*LOG(n)),因为price的范围比较小,可以用一个
hash[i]表示price为i的数量,然后线性的扫一遍就好了(类似桶排序吧)
于是优化到O(n)。
代码:
#include <fstream>
#define MAXPRICE 1001
using namespace std;
int main() {
ifstream fin ("milk.in");
ofstream fout ("milk.out");
unsigned int i, needed, price, paid, farmers, amount, milk[MAXPRICE];
paid = 0;
fin>>needed>>farmers;
for(i = 0;i<farmers;i++){
fin>>price>>amount;
milk[price] += amount;
}
for(i = 0; i<MAXPRICE && needed;i++){
if(needed> = milk[i]) {
needed -= milk[i];
paid += milk[i] * i;
} else if(milk[i][0]>0) {
paid += i*needed;
needed = 0;
}
}
fout << paid << endl;
return 0;
}