poj 2524 Ubiquitous Religions 【并查集】

Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 12445 Accepted: 5900

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7
第一个并查集程序,最小生成树不算。
 n个点,给你m条边,求最大能有多少个连通分量。
#include<iostream>
using namespace std;
const int MAX=50001;
int fa[MAX];

int find(int x)
{
    
return fa[x]==x?x:find(fa[x]);
}

void Union(int x, int y)
{
     fa[find(x)]
=find(y);
}
int main()
{
    
int n,m;
    
for(int tt=1; ; tt++)
    { 
              cin
>>n>>m;
             
if( n==0&&m==0)break;
             
             
for(int i=1; i<=n; i++)
                     fa[i]
=i; 
                     
             
int max=n;              
             
for(int i=1,s,t; i<=m; i++)
                     {
                         cin
>>s>>t;
                         
if(find(s)!=find(t))max=max-1;
                         Union(s,t);              
                     }
                     
             cout
<<"Case "<<tt<<':'<<' '<<max<<endl;
             
    }
    
    system(
"pause");    
    
return 0;
}


posted on 2010-08-26 19:20 田兵 阅读(313) 评论(0)  编辑 收藏 引用 所属分类: 算法笔记


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   博问   Chat2DB   管理


<2010年6月>
303112345
6789101112
13141516171819
20212223242526
27282930123
45678910

导航

统计

常用链接

留言簿(2)

随笔分类(65)

随笔档案(65)

文章档案(2)

ACM

搜索

积分与排名

最新随笔

最新评论

阅读排行榜