Cow Picnic
Time Limit: 2000 ms Memory Limit: 64 MB
Total Submission: 1 Accepted: 1
Description
The cows are having a picnic! Each of Farmer John's K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 ≤ M ≤ 10,000) one-way paths (no path connects a pasture to itself).
The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic locations.
Input
Line 1: Three space-separated integers, respectively: K, N, and M
Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing.
Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.
Output
Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.
Sample Input
2 4 4
2
3
1 2
1 4
2 3
3 4
Sample Output
Hint
The cows can meet in pastures 3 or 4.
Source
USACO 2006 December Silver
从每个牛开始求一次单源最短路径,假设起点是X,如果从X能到i (di[i]!=INF) ,cnt[i]++,用来统计能到达 i 点的牛的数量。
结果就是满足cnt[i]==K的数量,即i点所有的牛都可以到达。
用spfa求,spfa在这里不是求最段路径,只要到了就行,不需要是最短的,因此会更快一点。
#include<iostream>
#include<time.h>
#include<vector>
#include<queue>
using namespace std;
const int MAX=1001,INF=0x0fffffff;
vector<int> mp[MAX];
int d[MAX], cnt[MAX];
int K,N,M;
int stay[101];
void spfa(int x)
{
for(int i=1; i<=N; i++)
d[i]=INF;
queue<int>q;
q.push(x);
d[x]=0;
while(q.size())
{
int u=q.front(); q.pop();
for(int i=0; i<mp[u].size(); i++)
{
if(d[mp[u][i]]==INF)
{
d[mp[u][i]]=d[u]+1;
q.push(mp[u][i]);
}
}
}
}
int main()
{
cin>>K>>N>>M;
for(int i=1; i<=K; i++)
cin>>stay[i];
for(int i=1,s,t; i<=M; i++)
{
cin>>s>>t;
mp[s].push_back(t);
}
for(int i=1; i<=K; i++)
{
spfa(stay[i]);
for(int i=1; i<=N; i++)
if(d[i]!=INF)cnt[i]++;
}
int ans=0;
for(int i=1; i<=N; i++)
if(cnt[i]==K)ans++;
cout<<ans<<endl;
system("pause");
return 0;
}