农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了用最小的消费,他想铺设最短的光纤去连接所有的农场。你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。每两个农场间的距离不会超过100000
格式
PROGRAM NAME: agrinet
INPUT FORMAT:
(file agrinet.in)
第一行: 农场的个数,N(3<=N<=100)。
第二行..结尾: 后来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们限制在80个字符,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为不会有线路从第i个农场到它本身。
OUTPUT FORMAT:
(file agrinet.out)
只有一个输出,其中包含连接到每个农场的光纤的最小长度。
SAMPLE INPUT
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
SAMPLE OUTPUT
28
【参考程序】:
/*
ID: XIONGNA1
PROG: agrinet
LANG: C++
*/
#include<iostream>
using namespace std;
int cost[101][101],lowcost[101];
bool bo[101];
int mincost,n;
void prim()
{
int MIN,k;
for (int i=1;i<=n-1;i++)
{
MIN=0xFFFFFFF;
for (int j=1;j<=n;j++)
if (!bo[j] && lowcost[j]<MIN)
{
MIN=lowcost[j];
k=j;
}
if (MIN==32767) return ;
mincost+=MIN;
bo[k]=true;
for (int j=1;j<=n;j++)
if (!bo[j] && lowcost[j]>cost[k][j])
lowcost[j]=cost[k][j];
}
}
int main()
{
freopen("agrinet.in","r",stdin);
freopen("agrinet.out","w",stdout);
scanf("%d",&n);
for (int i=1;i<=n;i++)
for (int j=1;j<=n;j++)
scanf("%d",&cost[i][j]);
for (int i=1;i<=n;i++)
{
lowcost[i]=cost[1][i];
bo[i]=false;
}
bo[1]=true;
mincost=0;
prim();
printf("%d\n",mincost);
return 0;
}