The 2010 ACM-ICPC Asia Chengdu Regional Contest - C Binary Number 水题,枚举~

Binary Number

Time Limit: 2 Seconds      Memory Limit: 65536 KB

For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1, f(0, 3)=2, f(5, 10)=4.

Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integers in set A, choose the smallest one.

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output

For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input

2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

 

Sample Output

1
2
1
1
1
9999
0
不解释了,N2
 1# include <iostream>
 2# include <algorithm>
 3using namespace std;
 4int a[101],n,m;
 5int main()
 6{
 7    int t;
 8    cin>>t;
 9    while(t--)
10    {
11        cin>>n>>m;
12        for(int i=0;i<n;i++)
13           cin>>a[i];
14        sort(a,a+n);
15        for(int i=0;i<m;i++)
16        {
17           int t,res=0xfffffff,num;
18           cin>>t;
19           for(int j=0;j<n;j++)
20           {
21              int tmp1=a[j],tmp2=t,diff=0;
22              while(tmp1||tmp2)
23              {
24                 diff+=((tmp1&1)!=(tmp2&1));
25                 tmp1>>=1;
26                 tmp2>>=1;
27              }

28              if(diff<res) res=diff,num=a[j];
29           }

30           cout<<num<<endl;
31        }

32    }

33  //  system("pause");
34    return 0;
35}

36

posted on 2010-11-16 00:35 yzhw 阅读(313) 评论(0)  编辑 收藏 引用 所属分类: simple problem~


只有注册用户登录后才能发表评论。
网站导航: 博客园   IT新闻   BlogJava   知识库   博问   管理


<2011年1月>
2627282930311
2345678
9101112131415
16171819202122
23242526272829
303112345

导航

统计

公告

统计系统

留言簿(1)

随笔分类(227)

文章分类(2)

OJ

最新随笔

搜索

积分与排名

最新评论

阅读排行榜