Posted on 2010-08-08 22:18
MiYu 阅读(1125)
评论(4) 编辑 收藏 引用 所属分类:
ACM ( 模拟 ) 、
ACM ( 水题 )
MiYu原创, 转帖请注明 : 转载自 ______________白白の屋
题目地址:
http://acm.hdu.edu.cn/showproblem.php?pid=1228题目描述:
Problem Description
读入两个小于100的正整数A和B,计算A+B.
需要注意的是:A和B的每一位数字由对应的英文单词给出.
Input
测试输入包含若干测试用例,每个测试用例占一行,格式为"A + B =",相邻两字符串有一个空格间隔.当A和B同时为0时输入结束,相应的结果不要输出.
Output
对每个测试用例输出1行,即A+B的值.
Sample Input
one + two =
three four + five six =
zero seven + eight nine =
zero + zero =
Sample Output
3
90
96
简单的模拟题, 没什么技巧
代码如下:
MiYu原创, 转帖请注明 : 转载自 ______________白白の屋
#include <iostream>
#include <map>
using namespace std;
map < string, int > mp;
void setMap ()
{
mp["one"] = 1; mp["two"] = 2; mp["three"] = 3;
mp["four"] = 4; mp["five"] = 5; mp["six"] = 6;
mp["seven"] = 7; mp["eight"] = 8; mp["nine"] = 9;
mp["zero"] = 0;
}
int main ()
{
setMap ();
string a , b, c;
while ( cin >> a )
{
cin >> b;
int sum1 = mp[a];
while ( b != "+" )
{
sum1 = sum1 * 10 + mp[b];
cin >> b;
}
cin >> b;
int sum2 = mp[b];
cin >> b;
while ( b != "=" )
{
sum2 = sum2 * 10 + mp[b];
cin >> b;
}
if ( sum1 + sum2 == 0 )
{
break;
}
cout << sum1 + sum2 << endl;
}
return 0;
}