Closest Common Ancestors
Description
Write
a program that takes as input a rooted tree and a list of pairs of
vertices. For each pair (u,v) the program determines the closest common
ancestor of u and v in the tree. The closest common ancestor of two
nodes u and v is the node w that is an ancestor of both u and v and has
the greatest depth in the tree. A node can be its own ancestor (for
example in Figure 1 the ancestors of node 2 are 2 and 5)
Input
The data set, which is read from a the std input, starts with the tree description, in the form:
nr_of_vertices
vertex:(nr_of_successors) successor1 successor2 ... successorn
...
where vertices are represented as integers from 1 to n ( n <= 900
). The tree description is followed by a list of pairs of vertices, in
the form:
nr_of_pairs
(u v) (x y) ...
The input file contents several data sets (at least one).
Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.
Output
For
each common ancestor the program prints the ancestor and the number of
pair for which it is an ancestor. The results are printed on the
standard output on separate lines, in to the ascending order of the
vertices, in the format: ancestor:times
For example, for the following tree:
Sample Input
5
5:(3) 1 4 2
1:(0)
4:(0)
2:(1) 3
3:(0)
6
(1 5) (1 4) (4 2)
(2 3)
(1 3) (4 3)
Sample Output
2:1
5:5
题意:给出树的结构,再给出要询问的(u, v),求出询问后公共节点出现的个数。
代码:
#include <stdio.h>
#include <stdlib.h>
#include <vector>
#define maxn 1000
using namespace std;
int visit[maxn], in[maxn], f[maxn], anc[maxn], num[maxn];
vector<int> tree[maxn], que[maxn];
void set(int n)
{
for (int i = 1; i <= n; i++)
{
in[i] = 0;
visit[i] = 0;
num[i] = 0;
anc[i] = i;
f[i] = -1;
tree[i].clear();
que[i].clear();
}
}
int find(int a)
{
if (f[a] < 0)
{
return a;
}
return f[a] = find(f[a]);
}
void unions(int a, int b)
{
a = find(a);
b = find(b);
if (a != b)
{
if (f[a] > f[b])
{
f[b] += f[a];
f[a] = b;
}
else
{
f[a] += f[b];
f[b] = a;
}
}
}
void lca(int u)
{
int i, size;
size = tree[u].size();
for (i = 0; i < size; i++)
{
lca(tree[u][i]);
unions(u, tree[u][i]);
anc[find(u)] = u;
}
visit[u] = 1;
size = que[u].size();
for (i = 0; i < size; i++)
{
if (visit[que[u][i]] == 1)
{
num[anc[find(que[u][i])]]++;
}
}
}
int main()
{
char a[100], b[100];
int n, i, j, u, v, m;
while (scanf("%d", &n) != EOF)
{
set(n);
for (i = 0; i < n; i++)
{
scanf("%d:(%d)", &u, &m);
for (j = 0; j < m; j++)
{
scanf("%d", &v);
tree[u].push_back(v);
in[v]++;
}
}
scanf("%d", &m);
while (m--)
{
scanf(" (%d %d)", &u, &v);
que[u].push_back(v);
que[v].push_back(u);
}
for (i = 1; i <= n; i++)
{
if (in[i] == 0)
{
lca(i);
break;
}
}
for (i = 1; i <= n; i++)
{
if (num[i])
{
printf("%d:%d\n", i, num[i]);
}
}
}
system("pause");
return 0;
}