COURSES
Description
Consider
a group of N students and P courses. Each student visits zero, one or
more than one courses. Your task is to determine whether it is possible
to form a committee of exactly P students that satisfies simultaneously
the conditions:
- every student in the committee represents a different course (a student can represent a course if he/she visits that course)
- each course has a representative in the committee
Input
Your
program should read sets of data from the std input. The first line of
the input contains the number of the data sets. Each data set is
presented in the following format:
P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...
CountP StudentP 1 StudentP 2 ... StudentP CountP
The first line in each data set contains two positive integers
separated by one blank: P (1 <= P <= 100) - the number of courses
and N (1 <= N <= 300) - the number of students. The next P lines
describe in sequence of the courses �from course 1 to course P, each
line describing a course. The description of course i is a line that
starts with an integer Count i (0 <= Count i <= N) representing
the number of students visiting course i. Next, after a blank, you抣l
find the Count i students, visiting the course, each two consecutive
separated by one blank. Students are numbered with the positive integers
from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.
Output
The
result of the program is on the standard output. For each input data set
the program prints on a single line "YES" if it is possible to form a
committee and "NO" otherwise. There should not be any leading blanks at
the start of the line.
Sample Input
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
Sample Output
YES
NO
题意:给出课程数跟学生数,以及课程对应的学生。
求是否存在让所有课程跟不同的学生对应。
#include <stdio.h>
#include <stdlib.h>
#define maxn 310
int map[maxn][maxn], hash[maxn], pre[maxn], gn, gm;
//gn左边x的点数,gm右边y的点数
//pre是右边节点连接x中的节点
//hash是右边的节点有没有被访问过
void set()
{
for (int i = 1; i <= gn; i++)
{
for (int j = 1; j <= gm; j++)
{
map[i][j] = 0;
}
}
for (int j = 1; j <= gm; j++)
{
pre[j] = -1;
}
}
int han(int u)
{
for (int v = 1; v <= gm; v++)
{
if (hash[v] == 0 && map[u][v])//边存在且右节点没被访问过
{
hash[v] = 1;
if (pre[v] == -1 || han(pre[v]))//v还没有前置节点或v的前置节点存在增广路
{
pre[v] = u;//设定v的前置节点
return 1;
}
}
}
return 0;
}
int main()
{
int t, i, j, m, u, v, num;
scanf("%d", &t);
while (t--)
{
scanf("%d%d", &gn, &gm);
set();
for (i = 1; i <= gn; i++)
{
scanf("%d", &m);
while (m--)
{
scanf("%d", &v);
map[i][v] = 1;
}
}
for (i = 1, num = 0; i <= gn; i++)
{
for (j = 1; j <= gm; j++)
{
hash[j] = 0;
}
if (han(i))
{
num++;
}
}
if (num == gn)
{
printf("YES\n");
}
else
{
printf("NO\n");
}
}
system("pause");
return 0;
}