这个题目,我们让老师鄙视了。。。
Description
Famous Harry Potter,who seemd to be a normal and poor boy,is actually a wizard.Everything changed when he had his birthday of ten years old.A huge man called 'Hagrid' found Harry and lead him to a new world full of magic power.
If you've read this story,you probably know that Harry's parents had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the bank hold up by Goblins). And they stepped into the room which stored the fortune from his father.Harry was astonishing ,coz there were piles of gold coins.
The way of packing these coins by Goblins was really special.Only one coin was on the top,and three coins consisted an triangle were on the next lower layer.The third layer has six coins which were also consisted an triangle,and so on.On the ith layer there was an triangle have i coins each edge(totally i*(i+1)/2).The whole heap seemed just like a pyramid.Goblin still knew the total num of the layers,so it's up you to help Harry to figure out the sum of all the coins.
Input
The input will consist of some cases,each case takes a line with only one integer N( 0 < N < 2^31).It ends with a single 0.
Output
For each test case, output a line contains the number of all the coins, the format like the sample out(2 decimal digits).
Sample Input
1
3
0
Sample Output
1.00E0
1.00E1
Hint
when N=1 ,There is 1 gold coins.
when N=3 ,There is 1+3+6=10 gold coins.
题目很简单,求Sn=i*(i+1)/2的前n项和,n由题目给出。
平方和公式:1^2+2^2+3^2+...+n^2=n(n+1)(2*n+1)/6 等差求和:1+2+3+...+n=n*(n+1)/2
代码如下:
#include<stdio.h>
#include<math.h>
int main()
{
double test,sum;
int i;
scanf("%lf",&test);
while(test!=0)
{
sum=((test*(test+1)*(2*test+1))/6+(test*(test+1))/2)/2;
i=0;
while(sum>=10)
{
i++;
sum=sum/10;
}
printf("%.2fE%d\n",sum,i);
scanf("%lf",&test);
}
return 0;
}
posted on 2010-09-06 10:11
jince 阅读(473)
评论(0) 编辑 收藏 引用 所属分类:
Questions