A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?
Input Specification
Each line of input contains three positive floating point numbers giving the values of x, y, and c.
Output Specification
For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.
Sample Input
30 40 10
12.619429 8.163332 3
10 10 3
10 10 1
Sample Output
26.033
7.000
8.000
9.798
joj测试数据很弱,可能在其他oj上过不了,根据三角形相似得出以下关于w的方程,解w,第一次用二分法,不错。
f(w) = c - sqrt((y*y-w*w)*(x*x-w*w))/(sqrt(y*y-w*w) + sqrt(x*x -w*w))
#include<iostream>
#include<cstdlib>
#include<iomanip>
#include<math.h>
using namespace std;
//f(w) = c - sqrt((y*y-w*w)*(x*x-w*w))/(sqrt(y*y-w*w) + sqrt(x*x -w*w))
double func(double x,double y,double c)
{
double wdown=0.0,wup,w,fw;
if(x>y)
wup=y;
else
wup=x;
w=wup/2.0;
while(1)
{
fw=c-sqrt((y*y-w*w)*(x*x-w*w))/(sqrt(y*y-w*w) + sqrt(x*x -w*w));
if(fw>0.0001)
{
wup=w;
w=(wup+wdown)/2;
}
else
{
if(fw<-0.0001)
{
wdown=w;
w=(wup+wdown)/2;
}
else
{
return w;
}
}
}
}
int main()
{ //freopen("s.txt","r",stdin);
//freopen("key.txt","w",stdout);
double x,y,c;
while( cin>>x>>y>>c)
{
cout<<fixed<<setprecision(3)<<func(x,y,c)<<endl;
}
//system("PAUSE");
return 0;
}
posted on 2009-07-08 19:30
luis 阅读(548)
评论(0) 编辑 收藏 引用 所属分类:
贪心*二分