Description
Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。
Input
输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。
Output
输出最长区域的长度。
Sample Input
5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9
Sample Output
25
Source
#include <iostream>
const int MAXN = 110;
int map[MAXN][MAXN],dp[MAXN][MAXN];
int r,c,move[4][2]={-1,0,1,0,0,-1,0,1};
inline int MAX(int x,int y){
return x>y ? x : y;
}
int dfs(int x,int y){
if(dp[x][y]!=-1) return dp[x][y];
int i,xx,yy,max=0;
for(i=0;i<4;i++){
xx=x+move[i][0],yy=y+move[i][1];
if(map[x][y]>map[xx][yy] && xx>=0 && yy>=0 && xx<r && yy<c)
max=MAX(max,dfs(xx,yy)+1);
}
return max;
}
int main(){
int i,j,max=0;
scanf("%d %d",&r,&c);
for(i=0;i<r;i++)
for(j=0;j<c;j++){
scanf("%d",&map[i][j]);
dp[i][j]=-1;
}
for(i=0;i<r;i++)
for(j=0;j<c;j++){
dp[i][j]=dfs(i,j);
max=MAX(max,dp[i][j]);
}
printf("%d\n",max+1);
return 0;
}