Triangular Pastures
Time Limit:1000MS Memory Limit:30000K
Total Submit:1213 Accepted:291
Description
Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite.
I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length.
Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments.
Input
* Line 1: A single integer N
* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique.
Output
A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed.
Sample Input
5
1
1
3
3
4
Sample Output
692
Hint
[which is 100x the area of an equilateral triangle with side length 4]
Source
USACO 2002 February
由于数据量不大 利用可行性的状态 进行DP Heron公式
搜索也能过 呵呵 需要预先找到一个较好解 大->小搜 加一定的剪枝
#include <stdio.h>
#include <algorithm>
#include <functional>
#include <math.h>
using namespace std;
const int N = 40;
const int M = 1000; //边的最大可能长度(三角形性质)
bool s[N][M][M];
int seg[N+1];
inline double heron(double a, double b, double c) {
double p = (a+b+c)/2.0;
return sqrt(p*(p-a)*(p-b)*(p-c));
}
int main() {
int i, j, k, ns, tot = 0;
double best = 0, tmp;
scanf("%d", &ns);
for(i = 1; i <= ns; i++) { scanf("%d", seg+i); tot += seg[i]; }
s[0][0][0] = 1;
int bound = tot/2+1;
for(i = 1; i <= ns; i++)
for(j = 0; j<=bound; j++)
for(k = 0; k <=bound; k++)
s[i][j][k] = s[i-1][j][k] || j >= seg[i] && s[i-1][j-seg[i]][k] || k >= seg[i] && s[i-1][j][k-seg[i]];
for(j = 1; j<=bound; j++)
for(k = 1; k <=bound; k++) {
int m = tot-j-k;
if(s[ns][j][k] && j + k > m && j + m > k && m + k > j && (tmp = heron(j, k, m)) > best)
best = tmp;
}
if(best == 0) printf("-1\n");
else printf("%d\n", (int)(best*100));
return 0;
}