Organize Your Train part II
Time Limit:1000MS Memory Limit:65536K
Total Submit:417 Accepted:211
Description
RJ Freight, a Japanese railroad company for freight operations has recently constructed exchange lines at Hazawa, Yokohama. The layout of the lines is shown in Figure 1.
Figure 1: Layout of the exchange lines
A freight train consists of 2 to 72 freight cars. There are 26 types of freight cars, which are denoted by 26 lowercase letters from "a" to "z". The cars of the same type are indistinguishable from each other, and each car's direction doesn't matter either. Thus, a string of lowercase letters of length 2 to 72 is sufficient to completely express the configuration of a train.
Upon arrival at the exchange lines, a train is divided into two sub-trains at an arbitrary position (prior to entering the storage lines). Each of the sub-trains may have its direction reversed (using the reversal line). Finally, the two sub-trains are connected in either order to form the final configuration. Note that the reversal operation is optional for each of the sub-trains.
For example, if the arrival configuration is "abcd", the train is split into two sub-trains of either 3:1, 2:2 or 1:3 cars. For each of the splitting, possible final configurations are as follows ("+" indicates final concatenation position):
[3:1]
abc+d cba+d d+abc d+cba
[2:2]
ab+cd ab+dc ba+cd ba+dc cd+ab cd+ba dc+ab dc+ba
[1:3]
a+bcd a+dcb bcd+a dcb+a
Excluding duplicates, 12 distinct configurations are possible.
Given an arrival configuration, answer the number of distinct configurations which can be constructed using the exchange lines described above.
Input
The entire input looks like the following.
the number of datasets = m
1st dataset
2nd dataset
...
m-th dataset
Each dataset represents an arriving train, and is a string of 2 to 72 lowercase letters in an input line.
Output
For each dataset, output the number of possible train configurations in a line. No other characters should appear in the output.
Sample Input
4
aa
abba
abcd
abcde
Sample Output
1
6
12
18
真不好意思 最近生病了 好几天才回复你的问题
题目不难 简单模拟一下就可以了
但是我觉得直接做比较麻烦 推荐STL做吧
直接做可以用strrev等函数减少代码量
Solution
//by Optimistic
#include <string>
#include <iostream>
#include <algorithm>
#include <vector>
#include <set>
using namespace std;
int main()
{
int ns;
vector<string> vs;
int i;
scanf("%d", &ns);
while(ns--)
{
vs.clear();
string s;
cin >> s;
for(i=1; i<s.length(); i++)
{
string a = s.substr(0, i);
string b = s.substr(i);
vs.push_back(a+b);
vs.push_back(b+a);
string ra(a);
string rb(b);
reverse(ra.begin(), ra.end());
reverse(rb.begin(), rb.end());
vs.push_back(a+rb);
vs.push_back(ra+b);
vs.push_back(rb+a);
vs.push_back(b+ra);
vs.push_back(ra+rb);
vs.push_back(rb+ra);
}
set<string> ss(vs.begin(), vs.end());
cout << ss.size() << endl;
}
return 0;
}