A hard puzzle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2097 Accepted Submission(s): 688
Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
Output
For each test case, you should output the a^b's last digit number.
Sample Input
Sample Output
#include<iostream>
using namespace std;
int main() {
long a,b;
int t,x[6],i;
while(cin>>a>>b){
x[1]=a=a%10;
i=1;
do {
++i;
x[i]=(x[i-1]*a)%10;
}while(x[i]!=x[1]);
t=i-1;
x[0]=x[i-1];
printf("%d\n",x[b%t]);
}
return 0;
}
此处a,b要用long类型,开始用的整型,一直WA。。 - -!